Required Panopto Update

On July 29, Panopto will require all recorders to be updated to version 5.1 or 5.2. You will be prompted to update your recorder on this date, and will be unable to use Panopto until your version is updated to 5.1 or 5.2. If you are currently using a Maryville-issued computer, please contact the Help Desk to complete the update.

If you want to update your recorder before July 29, please visit http://learn.hosted.panopto.com, and sign in using Panopto Canvas Integration.
panopto_1

    1. Type your Maryville.edu username and password.
    2. Once logged in, click Download Panopto.
    panopto_2
    3. Click the appropriate Download Installer.
    panopto_3
    4. Once the software is downloaded, the installer opens and you can begin the installation process.

Even though Panopto is still available, we recommend using our new video platform, Kaltura, for future video recording needs.

References

Please contact LDT with questions.